Open Setup

Скрипт Open Setup 05.06

Нет прав для скачивания

audiofeel

Старожил
audiofeel updated Закос под Open Setup with a new update entry:

Choosing the installer language

Теперь можно выбрать язык установщика. Обновлено - FMXInno (версия от 16 января). IsArcExtract 0.4.0.1. Блокирование кнопки Next при нехватке свободного места на выбранном диске.
Read the rest of this update entry...
 

Andreo Fadio

Старожил
@audiofeel, а такое из-за чего получается?
а то во многих скриптах вами выложенными такое получается + еще некоторые непонятные моменты в других скриптах.
 

audiofeel

Старожил
а то во многих скриптах вами выложенными такое получается + еще некоторые непонятные моменты в других скриптах.
'Segoe Fluent Icons' шрифт не устанавливается у вас. хотя я обновил скрипт и он уже включен в установщик (до обновления его не было в установщике).
найдите вот эту строку
code_language.pascal:
function InitializeSetup: Boolean;
........
Result:= IsOSMatched(B_WIN10_1507);
и замените на это

code_language.pascal:
function InitializeSetup: Boolean;
.....
  Result:= True;
end;
 

audiofeel

Старожил
У вас случаем не на внешнем диске это все ? на флешках и внешних это все добро почему то не работает. автор dll знает, вернее сказать не знает почему это происходит, я не знаю что может препятствовать установке шрифтов. на 11ой при выключенном брандмауре шрифты не устанавливаются, как это связано
у вас какая система?
посмотрите вот этот пример, там шрифт 'Segoe UI Symbol' если у вас в ним все в порядке то попробуем подобрать значки от туда, ну или сами.
 

Вложения

Andreo Fadio

Старожил
посмотрите вот этот пример
Работает
У вас случаем не на внешнем диске это все ? на флешках и внешних это все добро почему то не работает
Случаем нет. Внутренний SSD на котором стоит система.
у вас какая система?
W10 22h2 (оригинальный образ, не сборка)
 

audiofeel

Старожил
вот это уже работает (хоть с какого накопителя)
А знаете почему? в Windows 10 уже есть шрифт Segoe MDL2 Assets, поэтому проблем с отображением символов нет. Но у вас явно с машиной что то не в порядке. Обратите внимание на скриншот который вы сделали с Segoe MDL2 Assets!! Со шрифтом Segoe MDL2 Assets
там все в порядке, он у вас на машине есть, а вот Roboto Condensed (который используется в примере для лейблов и текста) у вас нет. И на скриншоте это видно. Сейчас выложу скрин и будет понятно. P.S. Сходил к сыну в соседнюю комнату (у него Windows 10) у него с отображением все в порядке. больше пока мне проверить не на чем.
quoll510.png
 

Andreo Fadio

Старожил
Roboto Condensed (который используется в примере для лейблов и текста) у вас нет
Так в репаке он должен быть и активироваться, если на ПК пользователя его нет. А то смысл, если пользователю надо что-то докачивать.
Windows 10 уже есть шрифт Segoe MDL2 Assets, поэтому проблем с отображением символов нет
Так он же добавлен в сам пример.
Но у вас явно с машиной что то не в порядке.
С системой все в порядке, работает отлично. Это скрипты не довелены до ума :)
 

audiofeel

Старожил
Так в репаке он должен быть и активироваться, если на ПК пользователя его нет. А то смысл, если пользователю надо что-то докачивать
Он есть в репаке (этот шрифт Roboto Condensed )и активируется, только что проверил на двух разных ПК (Win 10 и Win 11). Только вы понять не можете или не хотите что он у вас не активируется и не устанавливается.

Так он же добавлен в сам пример
Ну хорошо, давайте я уберу его из сборки, и с символами у вас то же проблем не будет, потому что именно этот шрифт (Segoe MDL2 Assets)уже есть изначально в Windows 10. Но стоит мне поменять шрифт на тот которого у вас в системе нет - увас символы не отображаются.
Вот сборка вообще без установки шрифтов.
 

Вложения

audiofeel

Старожил
Что бы вы поняли что у вас не все в порядке с системой вот еще пример.
должно быть так
quoll515.png
у вас будет вот так
quoll516.png
 

Вложения

tihiy_don

Старожил
На виртуалке (чистая винда 10) запустил установщик, всё норм отображается. А вот на семёре не запускается, это нормально?
 
Последнее редактирование:
Сверху